Back to overview
Downtime

Cargo intelligence is unavailable

Feb 20, 2026 at 11:43am UTC
Affected services
Pandora Intelligence App :: Cargo Intelligence Plugin
Pandora Intelligence App :: Cargo Intelligence Waybill API
Pandora Intelligence App :: Cargo Intelligence ActionHub

Resolved
Feb 20, 2026 at 11:56am UTC

The earlier outage affecting Cargo Intelligence has been resolved. All services are now functioning normally. We will continue to monitor system performance closely. Thank you for your patience.

Created
Feb 20, 2026 at 11:43am UTC

We are currently experiencing an outage affecting Cargo Intelligence. Our team is actively investigating the issue and working to restore full service as soon as possible. Updates will follow.